NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

@payloadcms/next has Stored XSS in Admin PanelGHSA-mmxc-95ch-2j7c

HIGH

GHSA-mmxc-95ch-2j7c is a high-severity (CVSS 8.7) Cross-site Scripting (XSS) vulnerability in @payloadcms/next. A fix is available for @payloadcms/next — see the affected versions and patch details below.

Also known asCVE-2026-34748
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs22th percentile — riskier than 22% of all scored CVEsHighest risk
0.00%0.29%0.57%0.86%0.0%0.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

44other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@payloadcms/nextnpm
1.4Mdownloads / week

Description

Impact

A stored Cross-site Scripting (XSS) vulnerability existed in the admin panel. An authenticated user with write access to a collection could save content that, when viewed by another user, would execute in their browser.

Consumers are affected if ALL of these are true:

  • Payload version < v3.78.0
  • At least one collection with versions enabled
  • An authenticated user has create or update access to that collection

Patches

This vulnerability has been patched in v3.78.0. Output encoding has been added to prevent user-supplied content from being interpreted as markup.

Users should upgrade to v3.78.0 or later.

Workarounds

If consumers cannot upgrade immediately:

  • Restrict create and update access to versioned collections to trusted roles only.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@payloadcms/nextall versions3.78.0npm install @payloadcms/next@3.78.0

Affected Products

1 product · 1 configurations
Application
payloadpayloadcms
< 3.78.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @payloadcms/next, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @payloadcms/next to 3.78.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mmxc-95ch-2j7c is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact A stored Cross-site Scripting (XSS) vulnerability existed in the admin panel. An authenticated user with write access to a collection could save content that, when viewed by another user, would execute in their browser. Consumers are affected if ALL of these are true: - Payload version **< v3.78.0** - At least one collection with versions enabled - An authenticated user has `create` or `update` access to that collection ### Patches This vulnerability has been patched in **v3.78.0**. Output encoding has been added to prevent user-supplied content from being interpreted as markup
O3 Security · Impact-Aware SCA

Is GHSA-mmxc-95ch-2j7c in your dependencies?

Find it across npm, including transitive dependencies.

@payloadcms/next has Stored XSS in Admin Panel