NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2025-4644 — payload

Fix: payloadcms/payload@26d709d

CVE-2025-4644 is a CWE-384 vulnerability in payload. A fix is available for payload — see the affected versions and patch details below.

User Session Fixation after Account Removal in PayloadCMS

Also known asGHSA-26rv-h2hf-3fw4
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-4644.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk
0.00%0.31%0.62%0.93%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

114other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
payloadnpm
1.5Mdownloads / week
@payloadcms/nextnpm
1.4Mdownloads / week
@payloadcms/graphqlnpm
1.4Mdownloads / week

Description

A Session Fixation vulnerability existed in Payload's SQLite adapter due to identifier reuse during account creation. A malicious attacker could create a new account, save its JSON Web Token (JWT), and then delete the account, which did not invalidate the JWT. As a result, the next newly created user would receive the same identifier, allowing the attacker to reuse the JWT to authenticate and perform actions as that user.

This issue has been fixed in version 3.44.0 of Payload.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmpayloadall versions3.44.0npm install payload@3.44.0
📦npm@payloadcms/nextall versions3.44.0npm install @payloadcms/next@3.44.0
📦npm@payloadcms/graphqlall versions3.44.0npm install @payloadcms/graphql@3.44.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for payload, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update payload to 3.44.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-4644 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

A Session Fixation vulnerability existed in Payload's SQLite adapter due to identifier reuse during account creation. A malicious attacker could create a new account, save its JSON Web Token (JWT), and then delete the account, which did not invalidate the JWT. As a result, the next newly created user would receive the same identifier, allowing the attacker to reuse the JWT to authenticate and perform actions as that user. This issue has been fixed in version 3.44.0 of Payload.
O3 Security · Impact-Aware SCA

Is CVE-2025-4644 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2025-4644: payload — Fixed in 3.44.0