NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Tryton vulnerable to arbitrary command executionGHSA-m9jj-5qvj-5fhx

HIGHFix: tryton/trytond@19fc2a0

GHSA-m9jj-5qvj-5fhx is a high-severity (CVSS 8.8) CWE-77 vulnerability in tryton. A fix is available for tryton — see the affected versions and patch details below.

Also known asCVE-2014-6633PYSEC-2018-59PYSEC-2026-3390
Published
Updated
Affected
9 pkgs
Patched
9 / 9
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs85th percentile — riskier than 85% of all scored CVEsHighest risk
0.53%1.40%2.26%3.13%1.0%2.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍tryton🐍tryton🐍tryton🐍tryton🐍trytond🐍trytond🐍trytond🐍trytond+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The safe_eval function in trytond in Tryton before 2.4.15, 2.6.x before 2.6.14, 2.8.x before 2.8.11, 3.0.x before 3.0.7, and 3.2.x before 3.2.3 allows remote authenticated users to execute arbitrary commands via shell metacharacters in (1) the collection.domain in the webdav module or (2) the formula field in the price_list module.

Affected Packages

9 total 9 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItrytonall versions2.4.15pip install --upgrade 'tryton==2.4.15'
🐍PyPItryton≥ 2.6.0&&< 2.6.142.6.14pip install --upgrade 'tryton==2.6.14'
🐍PyPItryton≥ 2.8.0&&< 2.8.112.8.11pip install --upgrade 'tryton==2.8.11'
🐍PyPItryton≥ 3.2.0&&< 3.2.33.2.3pip install --upgrade 'tryton==3.2.3'
🐍PyPItrytond≥ 2.4.0&&< 2.4.152.4.15pip install --upgrade 'trytond==2.4.15'
🐍PyPItrytond≥ 2.6.0&&< 2.6.142.6.14pip install --upgrade 'trytond==2.6.14'

Affected Products

1 product · 5 configurations
Application
trytontryton
≥ 3.2.0 && < 3.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tryton, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update tryton to 2.4.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m9jj-5qvj-5fhx is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The `safe_eval` function in trytond in Tryton before 2.4.15, 2.6.x before 2.6.14, 2.8.x before 2.8.11, 3.0.x before 3.0.7, and 3.2.x before 3.2.3 allows remote authenticated users to execute arbitrary commands via shell metacharacters in (1) the `collection.domain` in the webdav module or (2) the formula field in the `price_list` module.
O3 Security · Impact-Aware SCA

Is GHSA-m9jj-5qvj-5fhx in your dependencies?

Find it across PyPI, including transitive dependencies.

Tryton vulnerable to arbitrary command execution