CVE-2014-6633 is a high-severity (CVSS 8.8) CWE-77 vulnerability in tryton. A fix is available for tryton — see the affected versions and patch details below.
Tryton vulnerable to arbitrary command execution
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
tryton🐍tryton🐍tryton🐍tryton🐍trytond🐍trytond🐍trytond🐍trytond+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The safe_eval function in trytond in Tryton before 2.4.15, 2.6.x before 2.6.14, 2.8.x before 2.8.11, 3.0.x before 3.0.7, and 3.2.x before 3.2.3 allows remote authenticated users to execute arbitrary commands via shell metacharacters in (1) the collection.domain in the webdav module or (2) the formula field in the price_list module.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | tryton | all versions | 2.4.15pip install --upgrade 'tryton==2.4.15' |
| 🐍PyPI | tryton | ≥ 2.6.0&&< 2.6.14 | 2.6.14pip install --upgrade 'tryton==2.6.14' |
| 🐍PyPI | tryton | ≥ 2.8.0&&< 2.8.11 | 2.8.11pip install --upgrade 'tryton==2.8.11' |
| 🐍PyPI | tryton | ≥ 3.2.0&&< 3.2.3 | 3.2.3pip install --upgrade 'tryton==3.2.3' |
| 🐍PyPI | trytond | ≥ 2.4.0&&< 2.4.15 | 2.4.15pip install --upgrade 'trytond==2.4.15' |
| 🐍PyPI | trytond | ≥ 2.6.0&&< 2.6.14 | 2.6.14pip install --upgrade 'trytond==2.6.14' |
Affected Products
trytontrytonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tryton, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tryton to 2.4.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-6633 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2014-6633 in your dependencies?
Find it across PyPI, including transitive dependencies.