CVE-2025-66422 — trytond
MEDIUMCVE-2025-66422 is a medium-severity (CVSS 4.3) CWE-402 vulnerability in trytond. A fix is available for trytond — see the affected versions and patch details below.
trytond allows remote attackers to obtain sensitive trace-back (server setup) information
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-66422.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
trytond🐍trytond🐍trytond🐍trytondReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Tryton trytond before 7.6.11 allows remote attackers to obtain sensitive trace-back (server setup) information. This is fixed in 7.6.11, 7.4.21, 7.0.40, and 6.0.70.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | trytond | ≥ 7.5.0&&< 7.6.11 | 7.6.11pip install --upgrade 'trytond==7.6.11' |
| 🐍PyPI | trytond | ≥ 7.1.0&&< 7.4.21 | 7.4.21pip install --upgrade 'trytond==7.4.21' |
| 🐍PyPI | trytond | ≥ 7.0.0&&< 7.0.40 | 7.0.40pip install --upgrade 'trytond==7.0.40' |
| 🐍PyPI | trytond | all versions | 6.0.70pip install --upgrade 'trytond==6.0.70' |
Affected Products
trytondtrytonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for trytond, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update trytond to 7.6.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-66422 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2025-66422 in your dependencies?
Find it across PyPI, including transitive dependencies.