BuddyPress privilege escalation via REST APIGHSA-m6j4-8r7p-wpp3
HIGHGHSA-m6j4-8r7p-wpp3 is a high-severity (CVSS 8.1) CWE-863 vulnerability in buddypress/buddypress. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for buddypress/buddypress — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
buddypress/buddypressReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
It's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the BuddyPress REST API members endpoint.
Patches
The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.
References
https://buddypress.org/2021/03/buddypress-7-2-1-security-release/
For more information
If you have any questions or comments about this advisory:
- Open an issue in HackerOne
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | buddypress/buddypress | ≥ 5.0.0&&< 7.2.1 | 7.2.1composer require buddypress/buddypress:^7.2.1 |
Affected Products
buddypressbuddypressResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for buddypress/buddypress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update buddypress/buddypress to 7.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m6j4-8r7p-wpp3 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect GHSA-m6j4-8r7p-wpp3
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-m6j4-8r7p-wpp3 -u https://target- Template
- BuddyPress REST API <7.2.1 - Privilege Escalation/Remote Code Execution
- Severity
- high
- Impact
- Successful exploitation of this vulnerability could allow an attacker to gain unauthorized access to sensitive information, escalate privileges, or execute arbitrary code on the affected system.
- Remediation
- This issue has been remediated in WordPress BuddyPress 7.2.1.
Template by ProjectDiscovery nuclei-templates (lotusdll), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-m6j4-8r7p-wpp3 in your dependencies?
Find it across Packagist, including transitive dependencies.