NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2017-6954 — buddypress

MEDIUMFix: boonebgorges/buddypress-docs@75293ed

CVE-2017-6954 is a medium-severity (CVSS 4.3) Improper Privilege Management vulnerability in buddypress/buddypress. A fix is available for buddypress/buddypress — see the affected versions and patch details below.

BuddyPress Docs plugin Improper Privilege Management

Also known asGHSA-9wf6-88x4-6xvj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%0.54%1.08%1.62%0.3%1.1%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘buddypress/buddypress

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in includes/component.php in the BuddyPress Docs plugin before 1.9.3 for WordPress. It is possible for authenticated users to edit documents of other users without proper permissions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbuddypress/buddypressall versions1.9.3composer require buddypress/buddypress:^1.9.3

Affected Products

1 product · 1 configurations
Application
buddypressbuddypress
≤ 1.9.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for buddypress/buddypress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update buddypress/buddypress to 1.9.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-6954 is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

An issue was discovered in includes/component.php in the BuddyPress Docs plugin before 1.9.3 for WordPress. It is possible for authenticated users to edit documents of other users without proper permissions.
O3 Security · Impact-Aware SCA

Is CVE-2017-6954 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2017-6954: buddypress — Fixed in 1.9.3