NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2020-5244 — buddypress

HIGHFix: buddypress/BuddyPress@3929468

CVE-2020-5244 is a high-severity (CVSS 7.5) CWE-284 vulnerability in buddypress/buddypress. A fix is available for buddypress/buddypress — see the affected versions and patch details below.

Private data exposure via REST API in BuddyPress

Also known asGHSA-3j78-7m59-r7gv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.63%1.40%2.17%2.94%1.1%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘buddypress/buddypress

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistbuddypress/buddypressall versions5.1.2composer require buddypress/buddypress:^5.1.2

Affected Products

1 product · 1 configurations
Application
buddypressbuddypress
≥ 5.0.0 && < 5.1.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for buddypress/buddypress, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update buddypress/buddypress to 5.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5244 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.
O3 Security · Impact-Aware SCA

Is CVE-2020-5244 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-5244: buddypress — Fixed in 5.1.2