NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Tryton allow authenticated users with certain permissions to read arbitrary files via the name parameterGHSA-jpr7-8rxm-4vgx

MEDIUM

GHSA-jpr7-8rxm-4vgx is a medium-severity (CVSS 4.4) Information Exposure vulnerability in trytond. A fix is available for trytond — see the affected versions and patch details below.

Also known asCVE-2016-1242PYSEC-2016-13PYSEC-2016-41
Published
Updated
Affected
5 pkgs
Patched
5 / 5
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.78%1.56%2.34%0.2%1.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

5 pkgs affected
🐍trytond🐍trytond🐍trytond🐍trytond🐍trytond

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

file_open in Tryton before 3.2.17, 3.4.x before 3.4.14, 3.6.x before 3.6.12, 3.8.x before 3.8.8, and 4.x before 4.0.4 allows remote authenticated users with certain permissions to read arbitrary files via the name parameter or unspecified other vectors.

Affected Packages

5 total 5 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPItrytondall versions3.2.17pip install --upgrade 'trytond==3.2.17'
🐍PyPItrytond≥ 3.4&&< 3.4.143.4.14pip install --upgrade 'trytond==3.4.14'
🐍PyPItrytond≥ 3.6&&< 3.6.123.6.12pip install --upgrade 'trytond==3.6.12'
🐍PyPItrytond≥ 3.8&&< 3.8.83.8.8pip install --upgrade 'trytond==3.8.8'
🐍PyPItrytond≥ 4.0&&< 4.0.44.0.4pip install --upgrade 'trytond==4.0.4'

Affected Products

1 product · 41 configurations
Application
trytontryton
≤ 3.2.16
39 versions
3.2.03.4.03.4.13.4.23.4.33.4.43.4.53.4.63.4.73.4.83.4.93.4.10

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for trytond, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update trytond to 3.2.17 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jpr7-8rxm-4vgx is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

`file_open` in Tryton before 3.2.17, 3.4.x before 3.4.14, 3.6.x before 3.6.12, 3.8.x before 3.8.8, and 4.x before 4.0.4 allows remote authenticated users with certain permissions to read arbitrary files via the name parameter or unspecified other vectors.
O3 Security · Impact-Aware SCA

Is GHSA-jpr7-8rxm-4vgx in your dependencies?

Find it across PyPI, including transitive dependencies.

Tryton allow authenticated users with certain permissions…