NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

@andrei-tatar/nora-firebase-common Prototype Pollution vulnerabilityGHSA-jjff-q3q4-5hh8

CRITICALFix: andrei-tatar/nora-firebase-common@bf30b75

GHSA-jjff-q3q4-5hh8 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in @andrei-tatar/nora-firebase-common. A fix is available for @andrei-tatar/nora-firebase-common — see the affected versions and patch details below.

Also known asCVE-2024-30564
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jjff-q3q4-5hh8.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.35%1.78%3.22%4.65%3.0%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@andrei-tatar/nora-firebase-commonnpm
472downloads / week

Description

An issue inandrei-tatar nora-firebase-common between v.1.0.41 and v.1.12.2 allows a remote attacker to execute arbitrary code via a crafted script to the updateState parameter of the updateStateInternal method.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@andrei-tatar/nora-firebase-common≥ 1.0.41&&< 1.12.31.12.3npm install @andrei-tatar/nora-firebase-common@1.12.3

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @andrei-tatar/nora-firebase-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @andrei-tatar/nora-firebase-common to 1.12.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jjff-q3q4-5hh8 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue inandrei-tatar nora-firebase-common between v.1.0.41 and v.1.12.2 allows a remote attacker to execute arbitrary code via a crafted script to the updateState parameter of the updateStateInternal method.
O3 Security · Impact-Aware SCA

Is GHSA-jjff-q3q4-5hh8 in your dependencies?

Find it across npm, including transitive dependencies.

@andrei-tatar/nora-firebase-common Prototype Pollution…