CVE-2024-30564 is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in @andrei-tatar/nora-firebase-common. A fix is available for @andrei-tatar/nora-firebase-common — see the affected versions and patch details below.
@andrei-tatar/nora-firebase-common Prototype Pollution vulnerability
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-30564.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@andrei-tatar/nora-firebase-commonnpmDescription
An issue inandrei-tatar nora-firebase-common between v.1.0.41 and v.1.12.2 allows a remote attacker to execute arbitrary code via a crafted script to the updateState parameter of the updateStateInternal method.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @andrei-tatar/nora-firebase-common | ≥ 1.0.41&&< 1.12.3 | 1.12.3npm install @andrei-tatar/nora-firebase-common@1.12.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @andrei-tatar/nora-firebase-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @andrei-tatar/nora-firebase-common to 1.12.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-30564 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-30564 in your dependencies?
Find it across npm, including transitive dependencies.