Deserialization of Untrusted Data in Archive_TarGHSA-jh5x-hfhg-78jq
HIGHFix: pear/Archive_Tar@0670a05GHSA-jh5x-hfhg-78jq is a high-severity (CVSS 7.8) Deserialization of Untrusted Data vulnerability in pear/archive_tar. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for pear/archive_tar — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pear/archive_tarReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Archive_Tar through 1.4.10 allows an unserialization attack because phar: is blocked but PHAR: is not blocked. See: https://github.com/pear/Archive_Tar/issues/33
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | pear/archive_tar | all versions | 1.4.11composer require pear/archive_tar:^1.4.11 |
Affected Products
debian linuxdebiandrupaldrupalfedorafedoraprojectarchive tarphpResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pear/archive_tar, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pear/archive_tar to 1.4.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jh5x-hfhg-78jq is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
PHP 7.2 and 7.3 marked End of Life at the time this CVE was released. There would be no patches made available for php-pear.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | php-pear-1:1.9.4-23.el7_9 | RHSA-2022:7340 |
| Red Hat Enterprise Linux 8 | php:7.4-8060020220907094815.5caa48ff | RHSA-2022:6542 |
| Red Hat Enterprise Linux 8.4 Extended Update Support | php:7.4-8040020220907095003.d7c09045 | RHSA-2022:6541 |
Frequently Asked Questions
Is GHSA-jh5x-hfhg-78jq in your dependencies?
Find it across Packagist, including transitive dependencies.