CVE-2018-1000888 is a high-severity (CVSS 8.8) Deserialization of Untrusted Data vulnerability in pear/archive_tar. 4 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for pear/archive_tar — see the affected versions and patch details below.
Archive_Tar contains Potential RCE if filename starts with phar://
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pear/archive_tarReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
PEAR Archive_Tar version 1.4.3 and earlier contains a CWE-502, CWE-915 vulnerability in the Archive_Tar class. There are several file operations with $v_header['filename'] as parameter (such as file_exists, is_file, is_dir, etc). When extract is called without a specific prefix path, we can trigger unserialization by crafting a tar file with phar://[path_to_malicious_phar_file] as path. Object injection can be used to trigger destruct in the loaded PHP classes, e.g. the Archive_Tar class itself. With Archive_Tar object injection, arbitrary file deletion can occur because @unlink($this->_temp_tarname) is called. If another class with useful gadget is loaded, it may possible to cause remote code execution that can result in files being deleted or possibly modified. This vulnerability appears to have been fixed in 1.4.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | pear/archive_tar | all versions | 1.4.4composer require pear/archive_tar:^1.4.4 |
Affected Products
ubuntu linuxcanonicaldebian linuxdebianpear archive tarphpResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
PEAR Archive_Tar < 1.4.4 - PHP Object Injection
by Fariskhi Vidyan · Jan 10, 2019
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pear/archive_tar, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pear/archive_tar to 1.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-1000888 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is CVE-2018-1000888 in your dependencies?
Find it across Packagist, including transitive dependencies.