CVE-2006-0931 — archive_tar
CRITICALCVE-2006-0931 is a critical-severity (CVSS 9.1) Path Traversal vulnerability in pear/archive_tar. A fix is available for pear/archive_tar — see the affected versions and patch details below.
PEAR::Archive_Tar Directory Traversal vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
pear/archive_tarReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Directory traversal vulnerability in PEAR::Archive_Tar 1.2, and other versions before 1.3.2, allows remote attackers to create and overwrite arbitrary files via certain crafted pathnames in a TAR archive.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | pear/archive_tar | ≥ 1.2&&< 1.3.2 | 1.3.2composer require pear/archive_tar:^1.3.2 |
Affected Products
pear archive tarpearDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pear/archive_tar, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update pear/archive_tar to 1.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2006-0931 is resolved across your whole dependency graph.
Workarounds
Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.
Frequently Asked Questions
Is CVE-2006-0931 in your dependencies?
Find it across Packagist, including transitive dependencies.