NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

OpenStack Horizon Cross-site scripting (XSS) vulnerabilityGHSA-j57p-g33w-95c5

Fix: openstack/horizon@32a7b71

GHSA-j57p-g33w-95c5 is a Cross-site Scripting (XSS) vulnerability in horizon. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for horizon — see the affected versions and patch details below.

Also known asCVE-2014-3474PYSEC-2026-644
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.00%0.81%1.62%2.43%0.3%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍horizon

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in horizon/static/horizon/js/horizon.instances.js in the Launch Instance menu in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-2 allows remote authenticated users to inject arbitrary web script or HTML via a network name.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIhorizonall versions8.0.0a0pip install --upgrade 'horizon==8.0.0a0'

Affected Products

2 products · 4 configurations
Application
horizonopenstack
≥ 2014.1 && < 2014.1.2
1 version
juno-1
OS
opensuseopensuse
1 version
13.1
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for horizon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update horizon to 8.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j57p-g33w-95c5 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack 4 for RHEL 6python-django-horizon-0:2013.2.3-3.el6ostRHSA-2014:1188
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7python-django-horizon-0:2014.1.1-2.el7ostRHSA-2014:0939

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in `horizon/static/horizon/js/horizon.instances.js` in the Launch Instance menu in OpenStack Dashboard (Horizon) before 2013.2.4, 2014.1 before 2014.1.2, and Juno before Juno-2 allows remote authenticated users to inject arbitrary web script or HTML via a network name.
O3 Security · Impact-Aware SCA

Is GHSA-j57p-g33w-95c5 in your dependencies?

Find it across PyPI, including transitive dependencies.

OpenStack Horizon Cross-site scripting (XSS) vulnerability