NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2015-3219 — horizon

MEDIUMFix: openstack/horizon@28d8f49

CVE-2015-3219 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in horizon. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for horizon — see the affected versions and patch details below.

OpenStack Dashboard (Horizon) Cross-site scripting (XSS) vulnerability

Also known asGHSA-rhjj-f6gq-6gx2PYSEC-2015-40
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.34%2.69%4.03%0.4%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍horizon

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the Orchestration/Stack section in OpenStack Dashboard (Horizon) 2014.2 before 2014.2.4 and 2015.1.x before 2015.1.1 allows remote attackers to inject arbitrary web script or HTML via the description parameter in a heat template, which is not properly handled in the help_text attribute in the Field class.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIhorizonall versions8.0.0a0pip install --upgrade 'horizon==8.0.0a0'

Affected Products

3 products · 7 configurations
OS
debian linuxdebian
1 version
8.0
Application
horizonopenstack
5 versions
2014.2.02014.2.12014.2.22014.2.32015.1.0
OS
solarisoracle
1 version
11.2
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for horizon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update horizon to 8.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-3219 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7python-django-horizon-0:2014.2.3-7.el7ostRHSA-2015:1679

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the Orchestration/Stack section in OpenStack Dashboard (Horizon) 2014.2 before 2014.2.4 and 2015.1.x before 2015.1.1 allows remote attackers to inject arbitrary web script or HTML via the description parameter in a heat template, which is not properly handled in the help_text attribute in the Field class.
O3 Security · Impact-Aware SCA

Is CVE-2015-3219 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2015-3219: horizon XSS — Fixed in 8.0.0a0