NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2017-7400 — horizon

MEDIUM

CVE-2017-7400 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in horizon. A fix is available for horizon — see the affected versions and patch details below.

OpenStack Horizon Cross-site Scripting (XSS)

Also known asGHSA-47vp-44v9-rhgqPYSEC-2026-821
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs65th percentile — riskier than 65% of all scored CVEsHighest risk
0.00%0.52%1.04%1.56%0.2%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍horizon🐍horizon🐍horizon

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Horizon 9.x through 9.1.1, 10.x through 10.0.2, and 11.0.0 allows remote authenticated administrators to conduct XSS attacks via a crafted federation mapping.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIhorizon≥ 9.0&&< 9.1.29.1.2pip install --upgrade 'horizon==9.1.2'
🐍PyPIhorizon≥ 10.0&&< 10.0.310.0.3pip install --upgrade 'horizon==10.0.3'
🐍PyPIhorizon≥ 11.0.0&&< 11.0.111.0.1pip install --upgrade 'horizon==11.0.1'

Affected Products

1 product · 19 configurations
Application
horizonopenstack
8 versions
9.0.09.0.19.1.09.1.110.0.010.0.110.0.211.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for horizon, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update horizon to 9.1.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-7400 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatLow
ProductFixed inAdvisory
Red Hat OpenStack Platform 10.0 (Newton)python-django-horizon-1:10.0.3-6.el7ostRHSA-2017:1598
Red Hat OpenStack Platform 9.0 (Mitaka)python-django-horizon-1:9.0.1-13.el7ostRHSA-2017:1739

Frequently Asked Questions

OpenStack Horizon 9.x through 9.1.1, 10.x through 10.0.2, and 11.0.0 allows remote authenticated administrators to conduct XSS attacks via a crafted federation mapping.
O3 Security · Impact-Aware SCA

Is CVE-2017-7400 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2017-7400: horizon XSS — Fixed in 9.1.2