NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

Denial of service vulnerability exists when System.IO.Pipelines improperly handles requestsGHSA-j378-6mmw-hqfr

HIGH

GHSA-j378-6mmw-hqfr is a high-severity (CVSS 7.5) vulnerability in Microsoft.AspNetCore.All. A fix is available for Microsoft.AspNetCore.All — see the affected versions and patch details below.

Also known asCVE-2018-8409
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
4.22%8.38%12.5%16.7%14.3%6.6%6.6%6.6%6.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
.NETMicrosoft.AspNetCore.All.NETMicrosoft.AspNetCore.App.NETSystem.IO.Pipelines

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service." This affects .NET Core 2.1, System.IO.Pipelines, ASP.NET Core 2.1.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMicrosoft.AspNetCore.All≥ 2.1.0&&< 2.1.42.1.4dotnet add package Microsoft.AspNetCore.All --version 2.1.4
.NETNuGetMicrosoft.AspNetCore.App≥ 2.1.0&&< 2.1.42.1.4dotnet add package Microsoft.AspNetCore.App --version 2.1.4
.NETNuGetSystem.IO.Pipelines≥ 4.5.0&&< 4.5.14.5.1dotnet add package System.IO.Pipelines --version 4.5.1

Affected Products

3 products · 3 configurations
Application
.net coremicrosoft
≥ 2.1 && < 2.1.4
range
Application
asp.net coremicrosoft
≥ 2.1 && < 2.1.4
range
Application
system.io.pipelinesmicrosoft
1 version
4.5.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.All, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Microsoft.AspNetCore.All to 2.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j378-6mmw-hqfr is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service." This affects .NET Core 2.1, System.IO.Pipelines, ASP.NET Core 2.1.
O3 Security · Impact-Aware SCA

Is GHSA-j378-6mmw-hqfr in your dependencies?

Find it across NuGet, including transitive dependencies.

Denial of service vulnerability exists when System.IO.Pipeli…