CVE-2018-8409 — Microsoft.AspNetCore.All
HIGHCVE-2018-8409 is a high-severity (CVSS 7.5) vulnerability in Microsoft.AspNetCore.All. A fix is available for Microsoft.AspNetCore.All — see the affected versions and patch details below.
Denial of service vulnerability exists when System.IO.Pipelines improperly handles requests
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Microsoft.AspNetCore.All.NETMicrosoft.AspNetCore.App.NETSystem.IO.PipelinesReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
A denial of service vulnerability exists when System.IO.Pipelines improperly handles requests, aka "System.IO.Pipelines Denial of Service." This affects .NET Core 2.1, System.IO.Pipelines, ASP.NET Core 2.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Microsoft.AspNetCore.All | ≥ 2.1.0&&< 2.1.4 | 2.1.4dotnet add package Microsoft.AspNetCore.All --version 2.1.4 |
| .NETNuGet | Microsoft.AspNetCore.App | ≥ 2.1.0&&< 2.1.4 | 2.1.4dotnet add package Microsoft.AspNetCore.App --version 2.1.4 |
| .NETNuGet | System.IO.Pipelines | ≥ 4.5.0&&< 4.5.1 | 4.5.1dotnet add package System.IO.Pipelines --version 4.5.1 |
Affected Products
.net coremicrosoftasp.net coremicrosoftsystem.io.pipelinesmicrosoftDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.All, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Microsoft.AspNetCore.All to 2.1.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-8409 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2018-8409 in your dependencies?
Find it across NuGet, including transitive dependencies.