CVE-2020-0602 — Microsoft.AspNetCore.All
HIGHCVE-2020-0602 is a high-severity (CVSS 7.5) vulnerability in Microsoft.AspNetCore.All. A fix is available for Microsoft.AspNetCore.All — see the affected versions and patch details below.
Denial of service in ASP.NET Core
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Microsoft.AspNetCore.All.NETMicrosoft.AspNetCore.App.NETMicrosoft.AspNetCore.App.NETMicrosoft.AspNetCore.App.NETMicrosoft.AspNetCore.Http.Connections.NETMicrosoft.AspNetCore.App.Runtime.linux-arm.NETMicrosoft.AspNetCore.App.Runtime.linux-arm64.NETMicrosoft.AspNetCore.App.Runtime.linux-musl-x64+5 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
A denial of service vulnerability exists when ASP.NET Core improperly handles web requests, aka 'ASP.NET Core Denial of Service Vulnerability'.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Microsoft.AspNetCore.All | ≥ 2.1.0&&< 2.1.15 | 2.1.15dotnet add package Microsoft.AspNetCore.All --version 2.1.15 |
| .NETNuGet | Microsoft.AspNetCore.App | ≥ 3.1.0&&< 3.1.1 | 3.1.1dotnet add package Microsoft.AspNetCore.App --version 3.1.1 |
| .NETNuGet | Microsoft.AspNetCore.App | ≥ 3.0.0&&< 3.0.1 | 3.0.1dotnet add package Microsoft.AspNetCore.App --version 3.0.1 |
| .NETNuGet | Microsoft.AspNetCore.App | ≥ 2.1.0&&< 2.1.15 | 2.1.15dotnet add package Microsoft.AspNetCore.App --version 2.1.15 |
| .NETNuGet | Microsoft.AspNetCore.Http.Connections | ≥ 1.0.0&&< 1.0.15 | 1.0.15dotnet add package Microsoft.AspNetCore.Http.Connections --version 1.0.15 |
| .NETNuGet | Microsoft.AspNetCore.App.Runtime.linux-arm | ≥ 3.1.0&&< 3.1.1 | 3.1.1dotnet add package Microsoft.AspNetCore.App.Runtime.linux-arm --version 3.1.1 |
Affected Products
asp.net coremicrosoftenterprise linuxredhatenterprise linux eusredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.All, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Microsoft.AspNetCore.All to 2.1.15 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-0602 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| .NET Core on Red Hat Enterprise Linux | rh-dotnet30-dotnet-0:3.0.102-3.el7 | RHSA-2020:0134 |
| Red Hat Enterprise Linux 8 | dotnet3.0-0:3.0.102-2.el8_1 | RHSA-2020:0130 |
Frequently Asked Questions
Is CVE-2020-0602 in your dependencies?
Find it across NuGet, including transitive dependencies.