GHSA-j2x6-9323-fp7h is a high-severity (CVSS 8.8) CWE-190 vulnerability in vyper. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for vyper — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
vyperReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
in the following code, the return of <iface>.returns_int128() is not validated to fall within the bounds of int128. as of v0.3.0, <iface>.returns_int128() is validated in simple expressions, but not complex expressions.
interface iface:
def returns_int128() -> int128: view
def returns_Bytes33() -> Bytes[33]: view
x: iface
@external
def call_out():
x: int128 = self.x.returns_int128() # affected, <0.3.0
y: uint256 = convert(self.x.returns_int128(), uint256) # affected, <0.3.2
z: Bytes[33] = concat(self.x.returns_Bytes33(), b"") # affected >= 0.3.0, <0.3.2
Patches
0.3.2 (as of https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b)
Workarounds
Break up operations involving external calls into multiple statements. For instance, instead of the example above, use
x: int128 = self.x.returns_int128()
y: uint256 = convert(x, uint256)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | vyper | all versions | 0.3.2pip install --upgrade 'vyper==0.3.2' |
Affected Products
vypervyperlangResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for vyper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update vyper to 0.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j2x6-9323-fp7h is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-j2x6-9323-fp7h in your dependencies?
Find it across PyPI, including transitive dependencies.