GHSA-hxrm-9w7p-39cc is a high-severity (CVSS 7.5) vulnerability in Microsoft.AspNetCore.Http. A fix is available for Microsoft.AspNetCore.Http — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-hxrm-9w7p-39cc.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
Microsoft.AspNetCore.Http.NETMicrosoft.AspNetCore.App.NETMicrosoft.Owin.NETMicrosoft.AspNetCore.App.Runtime.linux-arm.NETMicrosoft.AspNetCore.App.Runtime.linux-arm64.NETMicrosoft.AspNetCore.App.Runtime.linux-musl-x64.NETMicrosoft.AspNetCore.App.Runtime.linux-x64.NETMicrosoft.AspNetCore.App.Runtime.osx-x64+5 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
A security feature bypass vulnerability exists in the way Microsoft ASP.NET Core parses encoded cookie names.The ASP.NET Core cookie parser decodes entire cookie strings which could allow a malicious attacker to set a second cookie with the name being percent encoded.The security update addresses the vulnerability by fixing the way the ASP.NET Core cookie parser handles encoded names., aka 'Microsoft ASP.NET Core Security Feature Bypass Vulnerability'.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Microsoft.AspNetCore.Http | all versions | 2.1.22dotnet add package Microsoft.AspNetCore.Http --version 2.1.22 |
| .NETNuGet | Microsoft.AspNetCore.App | all versions | 2.1.22dotnet add package Microsoft.AspNetCore.App --version 2.1.22 |
| .NETNuGet | Microsoft.Owin | all versions | 4.1.1dotnet add package Microsoft.Owin --version 4.1.1 |
| .NETNuGet | Microsoft.AspNetCore.App.Runtime.linux-arm | ≥ 3.1.0&&< 3.1.8 | 3.1.8dotnet add package Microsoft.AspNetCore.App.Runtime.linux-arm --version 3.1.8 |
| .NETNuGet | Microsoft.AspNetCore.App.Runtime.linux-arm64 | ≥ 3.1.0&&< 3.1.8 | 3.1.8dotnet add package Microsoft.AspNetCore.App.Runtime.linux-arm64 --version 3.1.8 |
| .NETNuGet | Microsoft.AspNetCore.App.Runtime.linux-musl-x64 | ≥ 3.1.0&&< 3.1.8 | 3.1.8dotnet add package Microsoft.AspNetCore.App.Runtime.linux-musl-x64 --version 3.1.8 |
Affected Products
fedorafedoraprojectasp.net coremicrosoftenterprise linuxredhatenterprise linux ausredhatenterprise linux eusredhatenterprise linux tusredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Microsoft.AspNetCore.Http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Microsoft.AspNetCore.Http to 2.1.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hxrm-9w7p-39cc is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The "Cookie Prefixes" feature is not used by default in ASP.NET. Successful exploitation likely requires a secondary vulnerability, for example a cross-site scripting issue.
| Product | Fixed in | Advisory |
|---|---|---|
| .NET Core on Red Hat Enterprise Linux | rh-dotnet31-dotnet-0:3.1.108-1.el7 | RHSA-2020:3697 |
| Red Hat Enterprise Linux 8 | dotnet3.1-0:3.1.108-2.el8_2 | RHSA-2020:3699 |
Frequently Asked Questions
Is GHSA-hxrm-9w7p-39cc in your dependencies?
Find it across NuGet, including transitive dependencies.