NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

Improper Certificate Validation in Apache CXFGHSA-hgg6-8x62-m9gf

MEDIUMFix: apache/cxf@20d0fa3

GHSA-hgg6-8x62-m9gf is a medium-severity (CVSS 5.3) CWE-295 vulnerability in org.apache.cxf:cxf-core. EPSS puts its 30-day exploitation probability at 11.2% (96th percentile). A fix is available for org.apache.cxf:cxf-core — see the affected versions and patch details below.

Also known asCVE-2017-5653
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
11.2%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs96th percentile — riskier than 96% of all scored CVEsHighest risk
0.77%5.03%9.30%13.6%3.2%11.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.cxf:cxf-core☕org.apache.cxf:cxf-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

JAX-RS XML Security streaming clients in Apache CXF before 3.1.11 and 3.0.13 do not validate that the service response was signed or encrypted, which allows remote attackers to spoof servers.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.cxf:cxf-core≥ 3.1.0&&< 3.1.113.1.11org.apache.cxf:cxf-core:3.1.11
☕Mavenorg.apache.cxf:cxf-coreall versions3.0.13org.apache.cxf:cxf-core:3.0.13

Affected Products

1 product · 2 configurations
Application
cxfapache
≥ 3.1.0 && ≤ 3.1.11
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cxf:cxf-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.cxf:cxf-core to 3.1.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hgg6-8x62-m9gf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat JBoss A-MQ 6.3cxfRHSA-2017:1832

Frequently Asked Questions

JAX-RS XML Security streaming clients in Apache CXF before 3.1.11 and 3.0.13 do not validate that the service response was signed or encrypted, which allows remote attackers to spoof servers.
O3 Security · Impact-Aware SCA

Is GHSA-hgg6-8x62-m9gf in your dependencies?

Find it across Maven, including transitive dependencies.

Improper Certificate Validation in Apache CXF (Medium 5.3)