CVE-2014-0110 — cxf-core
Fix: apache/cxf@35cd292CVE-2014-0110 is a CWE-399 vulnerability in org.apache.cxf:cxf-core. A fix is available for org.apache.cxf:cxf-core — see the affected versions and patch details below.
Uncontrolled Resource Consumption in Apache CXF
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.apache.cxf:cxf-core☕org.apache.cxf:cxf-coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache CXF before 2.6.14 and 2.7.x before 2.7.11 allows remote attackers to cause a denial of service (/tmp disk consumption) via a large invalid SOAP message.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.cxf:cxf-core | all versions | 2.6.14org.apache.cxf:cxf-core:2.6.14 |
| ☕Maven | org.apache.cxf:cxf-core | ≥ 2.7.0&&< 2.7.11 | 2.7.11org.apache.cxf:cxf-core:2.7.11 |
Affected Products
cxfapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.cxf:cxf-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.cxf:cxf-core to 2.6.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-0110 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat JBoss A-MQ 6.1 | see advisory | RHSA-2014:1351 |
| Red Hat JBoss BPMS 6.0 | see advisory | RHSA-2015:0851 |
| Red Hat JBoss BRMS 6.0 | see advisory | RHSA-2015:0850 |
| Red Hat JBoss Enterprise Application Platform 6.2 | see advisory | RHSA-2014:0797 |
| Red Hat JBoss Enterprise Application Platform 6.2 for RHEL 5 | apache-cxf-0:2.7.11-3.redhat_3.1.ep6.el5 | RHSA-2014:0798 |
| Red Hat JBoss Enterprise Application Platform 6.2 for RHEL 6 | apache-cxf-0:2.7.11-3.redhat_3.1.ep6.el6 | RHSA-2014:0799 |
| Red Hat JBoss Portal 6.2 | see advisory | RHSA-2015:1009 |
Frequently Asked Questions
Is CVE-2014-0110 in your dependencies?
Find it across Maven, including transitive dependencies.