Pallets Werkzeug cross-site scripting vulnerabilityGHSA-h2fp-xgx6-xh6f
MEDIUMFix: pallets/werkzeug#1001GHSA-h2fp-xgx6-xh6f is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in werkzeug. A fix is available for werkzeug — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
werkzeugReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the render_full function in debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as used in Pallets Flask and other products) allows remote attackers to inject arbitrary web script or HTML via a field that contains an exception message.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | werkzeug | all versions | 0.11.11pip install --upgrade 'werkzeug==0.11.11' |
Affected Products
werkzeugpalletsprojectsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for werkzeug, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update werkzeug to 0.11.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-h2fp-xgx6-xh6f is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Satellite 6.6 for RHEL 7 | ansiblerole-foreman_scap_client-0:0.0.3-1.el7sat | RHSA-2019:3172 |
Frequently Asked Questions
Is GHSA-h2fp-xgx6-xh6f in your dependencies?
Find it across PyPI, including transitive dependencies.