Liferay Portal vulnerable to cross-site scripting in the Calendar widgetGHSA-gj92-p9mh-83j8
Fix: liferay/liferay-portal@ed066f1GHSA-gj92-p9mh-83j8 is a Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.calendar.web. A fix is available for com.liferay:com.liferay.calendar.web — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-gj92-p9mh-83j8.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
com.liferay:com.liferay.calendar.webReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the Calendar widget in Liferay Portal 7.4.3.35 through 7.4.3.110, and Liferay DXP 2023.Q4.0 through 2023.Q4.4, 2023.Q3.1 through 2023.Q3.6, 7.4 update 35 through update 92, and 7.3 update 25 through update 36 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into a Calendar's “Name” text field
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.liferay:com.liferay.calendar.web | ≥ 5.0.45&&< 5.0.87 | 5.0.87com.liferay:com.liferay.calendar.web:5.0.87 |
Affected Products
digital experience platformliferayliferay portalliferayDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.calendar.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.liferay:com.liferay.calendar.web to 5.0.87 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-gj92-p9mh-83j8 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-gj92-p9mh-83j8 in your dependencies?
Find it across Maven, including transitive dependencies.