NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2025-43818 — com.liferay.calendar.web

MEDIUMFix: liferay/liferay-portal@ed066f1

CVE-2025-43818 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in com.liferay:com.liferay.calendar.web. A fix is available for com.liferay:com.liferay.calendar.web — see the affected versions and patch details below.

Liferay Portal vulnerable to cross-site scripting in the Calendar widget

Also known asGHSA-gj92-p9mh-83j8
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2025-43818.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs13th percentile — riskier than 13% of all scored CVEsHighest risk
0.00%0.24%0.48%0.73%0.0%0.2%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.liferay:com.liferay.calendar.web

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in the Calendar widget in Liferay Portal 7.4.3.35 through 7.4.3.110, and Liferay DXP 2023.Q4.0 through 2023.Q4.4, 2023.Q3.1 through 2023.Q3.6, 7.4 update 35 through update 92, and 7.3 update 25 through update 36 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into a Calendar's “Name” text field

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.liferay:com.liferay.calendar.web≥ 5.0.45&&< 5.0.875.0.87com.liferay:com.liferay.calendar.web:5.0.87

Affected Products

2 products · 73 configurations
Application
digital experience platformliferay
≥ 2023.Q4.0 && < 2023.Q4.5
2 versions
7.37.4
Application
liferay portalliferay
≥ 7.4.3.35 && < 7.4.3.111
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay:com.liferay.calendar.web, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.liferay:com.liferay.calendar.web to 5.0.87 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-43818 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in the Calendar widget in Liferay Portal 7.4.3.35 through 7.4.3.110, and Liferay DXP 2023.Q4.0 through 2023.Q4.4, 2023.Q3.1 through 2023.Q3.6, 7.4 update 35 through update 92, and 7.3 update 25 through update 36 allows remote attackers to inject arbitrary web script or HTML via a crafted payload injected into a Calendar's “Name” text field
O3 Security · Impact-Aware SCA

Is CVE-2025-43818 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2025-43818: com.liferay.calendar — Fixed in 5.0.87