GHSA-g98m-96g9-wfjq is a high-severity (CVSS 7) CWE-427 vulnerability in bundler. A fix is available for bundler — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
bundlerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Bundler prior to 2.1.0 uses a predictable path in /tmp/, created with insecure permissions as a storage location for gems, if locations under the user's home directory are not available. If Bundler is used in a scenario where the user does not have a writable home directory, an attacker could place malicious code in this directory that would be later loaded and executed.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | bundler | ≥ 1.14.0&&< 2.1.0 | 2.1.0bundle update bundler --conservative |
Affected Products
bundlerbundlerDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bundler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update bundler to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g98m-96g9-wfjq is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
The version of rubygem-bundler provided in 'Red Hat Gluster Storage 3' does not contain the vulnerable functionality and is not affected by this vulnerability.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 8 | ruby:2.6-8040020210430142949.522a0ee4 | RHSA-2021:2588 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | rh-ruby26-ruby-0:2.6.7-119.el7 | RHSA-2021:2230 |
Frequently Asked Questions
Is GHSA-g98m-96g9-wfjq in your dependencies?
Find it across RubyGems, including transitive dependencies.