NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2019-3881 — bundler

HIGHFix: rubygems/bundler#7416

CVE-2019-3881 is a high-severity (CVSS 7.8) CWE-427 vulnerability in bundler. A fix is available for bundler — see the affected versions and patch details below.

Insecure path handling in Bundler

Also known asGHSA-g98m-96g9-wfjq
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs45th percentile — riskier than 45% of all scored CVEsHighest risk
0.00%0.34%0.69%1.03%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎bundler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Bundler prior to 2.1.0 uses a predictable path in /tmp/, created with insecure permissions as a storage location for gems, if locations under the user's home directory are not available. If Bundler is used in a scenario where the user does not have a writable home directory, an attacker could place malicious code in this directory that would be later loaded and executed.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsbundler≥ 1.14.0&&< 2.1.02.1.0bundle update bundler --conservative

Affected Products

1 product · 1 configurations
Application
bundlerbundler
< 2.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bundler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bundler to 2.1.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-3881 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

The version of rubygem-bundler provided in 'Red Hat Gluster Storage 3' does not contain the vulnerable functionality and is not affected by this vulnerability.

ProductFixed inAdvisory
Red Hat Enterprise Linux 8ruby:2.6-8040020210430142949.522a0ee4RHSA-2021:2588
Red Hat Software Collections for Red Hat Enterprise Linux 7rh-ruby26-ruby-0:2.6.7-119.el7RHSA-2021:2230

Frequently Asked Questions

Bundler prior to 2.1.0 uses a predictable path in /tmp/, created with insecure permissions as a storage location for gems, if locations under the user's home directory are not available. If Bundler is used in a scenario where the user does not have a writable home directory, an attacker could place malicious code in this directory that would be later loaded and executed.
O3 Security · Impact-Aware SCA

Is CVE-2019-3881 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2019-3881: bundler — Fixed in 2.1.0