NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2016-7954 — bundler

CRITICAL

CVE-2016-7954 is a critical-severity (CVSS 9.8) Code Injection vulnerability in bundler. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for bundler — see the affected versions and patch details below.

Bundler allows attacker to inject arbitrary code via secondary Gem source

Also known asGHSA-jvgm-pfqv-887x
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.8%probability of exploitation in next 30 days
Lower Risk+0.34%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
0.97%4.19%7.41%10.6%2.8%8.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎bundler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsbundler≥ 1.0.0&&< 2.0.02.0.0bundle update bundler --conservative

Affected Products

1 product · 183 configurations
Application
bundlerbundler
116 versions
1.0.01.0.11.0.21.0.31.0.41.0.51.0.61.0.71.0.81.0.91.0.101.0.11
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bundler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bundler to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2016-7954 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source. NOTE: this might overlap CVE-2013-0334.
O3 Security · Impact-Aware SCA

Is CVE-2016-7954 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2016-7954: bundler — Fixed in 2.0.0