NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

Symfony has an incorrect response from Validator when input ends with `\n`GHSA-g3rh-rrhp-jhh9

LOWFix: symfony/symfony@7d1032b

GHSA-g3rh-rrhp-jhh9 is a low-severity (CVSS 3.1) Improper Input Validation vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.

Also known asCVE-2024-50343
Published
Updated
Affected
6 pkgs
Patched
6 / 6
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-g3rh-rrhp-jhh9.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.32%0.64%0.96%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

6 pkgs affected
🐘symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/validator🐘symfony/validator🐘symfony/validator

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Description

It is possible to trick a Validator configured with a regular expression using the $ metacharacters, with an input ending with \n.

Resolution

Symfony now uses the D regex modifier to match the entire input.

The patch for this issue is available here for branch 5.4.

Credits

We would like to thank Offscript for reporting the issue and Alexandre Daubois for providing the fix.

Affected Packages

6 total 6 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsymfony/symfonyall versions5.4.43composer require symfony/symfony:^5.4.43
🐘Packagistsymfony/symfony≥ 6.0.0&&< 6.4.116.4.11composer require symfony/symfony:^6.4.11
🐘Packagistsymfony/symfony≥ 7.0.0&&< 7.1.47.1.4composer require symfony/symfony:^7.1.4
🐘Packagistsymfony/validatorall versions5.4.43composer require symfony/validator:^5.4.43
🐘Packagistsymfony/validator≥ 6.0.0&&< 6.4.116.4.11composer require symfony/validator:^6.4.11
🐘Packagistsymfony/validator≥ 7.0.0&&< 7.1.47.1.4composer require symfony/validator:^7.1.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update symfony/symfony to 5.4.43 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g3rh-rrhp-jhh9 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Description It is possible to trick a `Validator` configured with a regular expression using the `$` metacharacters, with an input ending with `\n`. ### Resolution Symfony now uses the `D` regex modifier to match the entire input. The patch for this issue is available [here](https://github.com/symfony/symfony/commit/7d1032bbead9a4229b32fa6ebca32681c80cb76f) for branch 5.4. ### Credits We would like to thank Offscript for reporting the issue and Alexandre Daubois for providing the fix.
O3 Security · Impact-Aware SCA

Is GHSA-g3rh-rrhp-jhh9 in your dependencies?

Find it across Packagist, including transitive dependencies.

Symfony has an incorrect response from Validator when…