CVE-2024-50343 is a low-severity (CVSS 3.1) Improper Input Validation vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Incorrect response from Validator when input ends with `\n` in symfony/validator
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2024-50343.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/validator🐘symfony/validator🐘symfony/validatorReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
symfony/validator is a module for the Symphony PHP framework which provides tools to validate values. It is possible to trick a Validator configured with a regular expression using the $ metacharacters, with an input ending with \n. Symfony as of versions 5.4.43, 6.4.11, and 7.1.4 now uses the D regex modifier to match the entire input. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | all versions | 5.4.43composer require symfony/symfony:^5.4.43 |
| 🐘Packagist | symfony/symfony | ≥ 6.0.0&&< 6.4.11 | 6.4.11composer require symfony/symfony:^6.4.11 |
| 🐘Packagist | symfony/symfony | ≥ 7.0.0&&< 7.1.4 | 7.1.4composer require symfony/symfony:^7.1.4 |
| 🐘Packagist | symfony/validator | all versions | 5.4.43composer require symfony/validator:^5.4.43 |
| 🐘Packagist | symfony/validator | ≥ 6.0.0&&< 6.4.11 | 6.4.11composer require symfony/validator:^6.4.11 |
| 🐘Packagist | symfony/validator | ≥ 7.0.0&&< 7.1.4 | 7.1.4composer require symfony/validator:^7.1.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 5.4.43 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-50343 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2024-50343 in your dependencies?
Find it across Packagist, including transitive dependencies.