CakePHP allows remote attackers to modify internal Cake cache and execute arbitrary codeGHSA-g2vx-8v47-4vhh
Fix: cakephp/cakephp@e431e86GHSA-g2vx-8v47-4vhh is a Improper Input Validation vulnerability in cakephp/cakephp. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for cakephp/cakephp — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
cakephp/cakephpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The _validatePost function in libs/controller/components/security.php in CakePHP 1.3.x through 1.3.5 and 1.2.8 allows remote attackers to modify the internal Cake cache and execute arbitrary code via a crafted data[_Token][fields] value that is processed by the unserialize function, as demonstrated by modifying the file_map cache to execute arbitrary local files.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | cakephp/cakephp | ≥ 1.2.8&&< 1.3.6 | 1.3.6composer require cakephp/cakephp:^1.3.6 |
Affected Products
cakephpcakefoundationcakephpcakephpResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
CakePHP 1.3.5/1.2.8 - 'Unserialize()' File Inclusion
by felix · Jan 18, 2011
CakePHP 1.3.5/1.2.8 - Cache Corruption (Metasploit)
by Metasploit · Jan 14, 2011
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/cakephp, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cakephp/cakephp to 1.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-g2vx-8v47-4vhh is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-g2vx-8v47-4vhh in your dependencies?
Find it across Packagist, including transitive dependencies.