NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

OpenStack Object Storage (Swift) allows remote attackers to cause a denial of serviceGHSA-fxwr-2vxm-cg7p

HIGH

GHSA-fxwr-2vxm-cg7p is a high-severity (CVSS 7.5) CWE-399 vulnerability in swift. A fix is available for swift — see the affected versions and patch details below.

Also known asCVE-2016-0738PYSEC-2026-932
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk+0.11%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
3.23%4.28%5.33%6.39%5.8%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍swift🐍swift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIswiftall versions2.3.1pip install --upgrade 'swift==2.3.1'
🐍PyPIswift≥ 2.4.0&&< 2.5.12.5.1pip install --upgrade 'swift==2.5.1'

Affected Products

1 product · 3 configurations
Application
swiftopenstack
≤ 2.3.0
2 versions
2.4.02.5.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update swift to 2.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fxwr-2vxm-cg7p is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6openstack-swift-0:1.13.1-8.el6ostRHSA-2016:0126
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7openstack-swift-0:1.13.1-8.el7ostRHSA-2016:0127
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7openstack-swift-0:2.2.0-6.el7ostRHSA-2016:0128
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7openstack-swift-0:2.3.0-3.el7ostRHSA-2016:0155
Red Hat Gluster Storage 3.1 for RHEL 6openstack-swift-0:1.13.1-8.el6ostRHSA-2016:0329
Red Hat Gluster Storage 3.1 for RHEL 7openstack-swift-0:1.13.1-8.el7ostRHSA-2016:0328

Frequently Asked Questions

OpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.
O3 Security · Impact-Aware SCA

Is GHSA-fxwr-2vxm-cg7p in your dependencies?

Find it across PyPI, including transitive dependencies.

OpenStack Object Storage (Swift) allows remote attackers…