CVE-2014-7960 — swift
Fix: openstack/swift@06800cbCVE-2014-7960 is a CWE-399 vulnerability in swift. A fix is available for swift — see the affected versions and patch details below.
OpenStack Swift metadata constraints are not correctly enforced
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
swiftReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Object Storage (Swift) before 2.2.0 allows remote authenticated users to bypass the max_meta_count and other metadata constraints via multiple crafted requests which exceed the limit when combined.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | swift | all versions | 2.2.0pip install --upgrade 'swift==2.2.0' |
Affected Products
swiftopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update swift to 2.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2014-7960 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Native Client for RHEL 5 for Red Hat Storage | glusterfs-0:3.7.1-11.el5 | RHSA-2015:1495 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | openstack-swift-0:1.13.1-4.el6ost | RHSA-2015:0836 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | openstack-swift-0:1.13.1-4.el7ost | RHSA-2015:0835 |
Frequently Asked Questions
Is CVE-2014-7960 in your dependencies?
Find it across PyPI, including transitive dependencies.