NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2022-47950 — swift

MEDIUMFix: openstack/swift@12e5439

CVE-2022-47950 is a medium-severity (CVSS 6.5) CWE-552 vulnerability in swift. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for swift — see the affected versions and patch details below.

OpenStack Swift XML external entities (XXE) Injection

Also known asGHSA-274c-rx2j-2v3xPYSEC-2026-927
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2022-47950.

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs64th percentile — riskier than 64% of all scored CVEsHighest risk
0.00%0.51%1.01%1.52%0.2%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍swift🐍swift🐍swift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in OpenStack Swift before 2.28.1, 2.29.x before 2.29.2, and 2.30.0. By supplying crafted XML files, an authenticated user may coerce the S3 API into returning arbitrary file contents from the host server, resulting in unauthorized read access to potentially sensitive data. This impacts both s3api deployments (Rocky or later), and swift3 deployments (Queens and earlier, no longer actively developed).

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIswiftall versions2.28.1pip install --upgrade 'swift==2.28.1'
🐍PyPIswift≥ 2.29.0&&< 2.29.22.29.2pip install --upgrade 'swift==2.29.2'
🐍PyPIswift≥ 2.30.0&&< 2.30.12.30.1pip install --upgrade 'swift==2.30.1'

Affected Products

2 products · 4 configurations
OS
debian linuxdebian
1 version
10.0
Application
swiftopenstack
≥ 2.29.0 && < 2.29.2
1 version
2.30.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update swift to 2.28.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-47950 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Red Hat OpenStack Platform 13.0 - ELSopenstack-swift-plugin-swift3-0:1.12.1-1.el7ostRHSA-2023:1277
Red Hat OpenStack Platform 17.0openstack-swift-0:2.27.1-0.20230201120900.6a1a8ce.el9ostRHSA-2023:1013

Frequently Asked Questions

An issue was discovered in OpenStack Swift before 2.28.1, 2.29.x before 2.29.2, and 2.30.0. By supplying crafted XML files, an authenticated user may coerce the S3 API into returning arbitrary file contents from the host server, resulting in unauthorized read access to potentially sensitive data. This impacts both s3api deployments (Rocky or later), and swift3 deployments (Queens and earlier, no longer actively developed).
O3 Security · Impact-Aware SCA

Is CVE-2022-47950 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2022-47950: swift — Fixed in 2.28.1