NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2012-4406 — swift

CRITICALFix: openstack/swift@e1ff51c

CVE-2012-4406 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in swift. A fix is available for swift — see the affected versions and patch details below.

OpenStack Object Storage (swift) Code Injection vulnerability

Also known asGHSA-v7mh-3jgf-r26cPYSEC-2026-545
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
4.15%5.14%6.14%7.13%4.7%6.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍swift

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

OpenStack Object Storage (swift) before 1.7.0 uses the loads function in the pickle Python module unsafely when storing and loading metadata in memcached, which allows remote attackers to execute arbitrary code via a crafted pickle object.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIswiftall versions1.7.0pip install --upgrade 'swift==1.7.0'

Affected Products

7 products · 8 configurations
OS
fedorafedoraproject
1 version
16
Application
swiftopenstack
< 1.7.0
range
OS
enterprise linux serverredhat
2 versions
5.06.0
Application
gluster storage management consoleredhat
1 version
2.0
Application
gluster storage server for on-premiseredhat
1 version
2.0
Application
storageredhat
1 version
2.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for swift, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update swift to 1.7.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-4406 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
ProductFixed inAdvisory
Native Client for RHEL 5 for Red Hat Storageglusterfs-0:3.3.0.7rhs-1.el5RHSA-2013:0691
OpenStack Essex for RHEL 6openstack-swift-0:1.4.8-5.el6RHSA-2012:1379

Frequently Asked Questions

OpenStack Object Storage (swift) before 1.7.0 uses the loads function in the pickle Python module unsafely when storing and loading metadata in memcached, which allows remote attackers to execute arbitrary code via a crafted pickle object.
O3 Security · Impact-Aware SCA

Is CVE-2012-4406 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2012-4406: swift RCE — Fixed in 1.7.0