Stored XSS by authenticated backend user with access to upload filesGHSA-fx3v-553x-3c4q
LOWFix: octobercms/library@80aab47GHSA-fx3v-553x-3c4q is a low-severity (CVSS 2.8) Cross-site Scripting (XSS) vulnerability in october/backend. A fix is available for october/backend — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
october/backendReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Backend users with access to upload files were permitted to upload SVG files without any sanitization applied to the uploaded files. Since SVG files support being parsed as HTML by browsers, this means that they could theoretically upload Javascript that would be executed on a path under the website's domain (i.e. /storage/app/media/evil.svg), but they would have to convince their target to visit that location directly in the target's browser as the backend does not display SVGs inline anywhere, SVGs are only displayed as image resources in the backend and are thus unable to be executed.
Patches
Issue has been patched in Build 469 (v1.0.469) & v1.1.0.
Workarounds
Apply https://github.com/octobercms/library/commit/80aab47f044a2660aa352450f55137598f362aa4 to your installation manually if unable to upgrade to Build 469 or v1.1.0.
References
Reported by Hoan Hoang
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected]
Threat assessment:
<img width="1107" alt="Screen Shot 2020-10-10 at 1 47 49 PM" src="https://user-images.githubusercontent.com/7253840/95663787-378f2b80-0aff-11eb-8dfc-b97d162939da.png">Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | october/backend | ≥ 1.0.319&&< 1.0.469 | 1.0.469composer require october/backend:^1.0.469 |
Affected Products
octoberoctobercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update october/backend to 1.0.469 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fx3v-553x-3c4q is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-fx3v-553x-3c4q in your dependencies?
Find it across Packagist, including transitive dependencies.