NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2020-4061 — backend

MEDIUMFix: octobercms/october@b384954

CVE-2020-4061 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in october/backend. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for october/backend — see the affected versions and patch details below.

Cross-site Scripting in October

Also known asGHSA-3pc2-fm7p-q2vg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs57th percentile — riskier than 57% of all scored CVEsHighest risk
0.00%0.44%0.88%1.32%0.3%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘october/backend

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Pasting content copied from malicious websites into the Froala richeditor could result in a successful self-XSS attack.

Patches

Issue has been patched in Build 467 (v1.0.467).

Workarounds

Apply https://github.com/octobercms/october/commit/b384954a29b89117e1c0d6035b3ede4f46df67c5 to your installation manually if unable to upgrade to Build 467.

References

For more information

If you have any questions or comments about this advisory:

Threat Assessment

Assessed as Low given that by the nature of the attack it can only impact users that do it to themselves by copying and pasting from malicious websites.

Acknowledgements

Thanks to Michał Bentkowski of Securitum for finding the original issue in Froala and @tomaszstrojny for reporting the issue to the October CMS team.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistoctober/backend≥ 1.0.319&&< 1.0.4671.0.467composer require october/backend:^1.0.467

Affected Products

1 product · 1 configurations
Application
octoberoctobercms
≥ 1.0.319 && < 1.0.467
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for october/backend, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update october/backend to 1.0.467 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-4061 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

### Impact Pasting content copied from malicious websites into the Froala richeditor could result in a successful self-XSS attack. ### Patches Issue has been patched in Build 467 (v1.0.467). ### Workarounds Apply https://github.com/octobercms/october/commit/b384954a29b89117e1c0d6035b3ede4f46df67c5 to your installation manually if unable to upgrade to Build 467. ### References - https://research.securitum.com/the-curious-case-of-copy-paste/ ### For more information If you have any questions or comments about this advisory: * Email us at [[email protected]](mailto:[email protected]) #
O3 Security · Impact-Aware SCA

Is CVE-2020-4061 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-4061: backend XSS — Fixed in 1.0.467