NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

GeSHi vulnerable to Directory TraversalGHSA-fw3x-2pr2-5j64

GHSA-fw3x-2pr2-5j64 is a Path Traversal vulnerability in geshi/geshi. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for geshi/geshi — see the affected versions and patch details below.

Also known asCVE-2012-3521
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs88th percentile — riskier than 88% of all scored CVEsHighest risk
0.00%1.32%2.64%3.96%0.6%3.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘geshi/geshi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before 1.0.8.11 allow remote attackers to read arbitrary files via a .. (dot dot) in the (1) geshi-path or (2) geshi-lang-path parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgeshi/geshiall versions1.0.8.11composer require geshi/geshi:^1.0.8.11

Affected Products

1 product · 7 configurations
Application
geshiqbnz
≤ 1.0.8.10
6 versions
1.0.8.41.0.8.51.0.8.61.0.8.71.0.8.81.0.8.9
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for geshi/geshi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update geshi/geshi to 1.0.8.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fw3x-2pr2-5j64 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before 1.0.8.11 allow remote attackers to read arbitrary files via a .. (dot dot) in the (1) geshi-path or (2) geshi-lang-path parameter.
O3 Security · Impact-Aware SCA

Is GHSA-fw3x-2pr2-5j64 in your dependencies?

Find it across Packagist, including transitive dependencies.

GeSHi vulnerable to Directory Traversal