NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CVE-2012-3522 — geshi

CVE-2012-3522 is a Cross-site Scripting (XSS) vulnerability in geshi/geshi. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for geshi/geshi — see the affected versions and patch details below.

GeSHi vulnerable to Cross-site Scripting

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.74%0.3%1.2%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐘geshi/geshi

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistgeshi/geshiall versions1.0.8.11composer require geshi/geshi:^1.0.8.11

Affected Products

1 product · 7 configurations
Application
geshiqbnz
≤ 1.0.8.10
6 versions
1.0.8.41.0.8.51.0.8.61.0.8.71.0.8.81.0.8.9
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for geshi/geshi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update geshi/geshi to 1.0.8.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2012-3522 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site scripting (XSS) vulnerability in contrib/langwiz.php in GeSHi before 1.0.8.11 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
O3 Security · Impact-Aware SCA

Is CVE-2012-3522 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2012-3522: geshi XSS — Fixed in 1.0.8.11