NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

Dependency Confusion in BundlerGHSA-fp4w-jxhp-m23p

HIGHFix: rubygems/rubygems#4609

GHSA-fp4w-jxhp-m23p is a high-severity (CVSS 8.8) vulnerability in bundler. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for bundler — see the affected versions and patch details below.

Also known asCVE-2020-36327
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
6.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
0.64%10.7%20.8%30.9%25.2%6.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎bundler💎bundler

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every "Dependency Confusion" issue in every product.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsbundler≥ 1.16.0&&< 2.2.102.2.10bundle update bundler --conservative
💎RubyGemsbundler≥ 2.2.11&&< 2.2.182.2.18bundle update bundler --conservative

Affected Products

3 products · 4 configurations
Application
bundlerbundler
≥ 2.2.11 && ≤ 2.2.16
range
OS
fedorafedoraproject
1 version
34
Application
package manager configurationsmicrosoft
all
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for bundler, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update bundler to 2.2.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-fp4w-jxhp-m23p is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

Red Hat Satellite does not ship RubyGem bundler, however, the product consumes it from the Red Hat Software Collections (RHSCL) repository.

Workaround published by Red Hat
This issue only affects configurations where gem packages are installed from multiple sources and the source repositories are explicitly defined for at least some gems. Dependencies of those source-restricted gems may be installed form a different repository, even if the same repository provides those dependencies, which is inconsistent with the intended behaviour described in the Bundler documentation. There are multiple possible approaches to mitigate this issue - customers should evaluate which approaches are usable in their environments. * Explicitly define source for all dependency gems in the Gemfile configuration. When a dependency of a source-restricted gem is also to be installed…
Source: Red Hat security advisory for GHSA-fp4w-jxhp-m23p (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 8ruby:2.7-8040020210728141159.522a0ee4RHSA-2021:3020
Red Hat Enterprise Linux 8ruby:2.6-8050020211215144356.c5368500RHSA-2022:0543
Red Hat Enterprise Linux 8ruby:2.5-8050020220112131355.c5368500RHSA-2022:0545
Red Hat Enterprise Linux 8.1 Update Services for SAP Solutionsruby:2.5-8010020220201125517.c27ad7f8RHSA-2022:0548
Red Hat Enterprise Linux 8.1 Update Services for SAP Solutionsruby:2.6-8010020220201152941.c27ad7f8RHSA-2022:0581
Red Hat Enterprise Linux 8.2 Extended Update Supportruby:2.5-8020020220201125131.4cda2c84RHSA-2022:0547
Red Hat Enterprise Linux 8.2 Extended Update Supportruby:2.6-8020020220201131207.4cda2c84RHSA-2022:0582
Red Hat Enterprise Linux 8.4 Extended Update Supportruby:2.6-8040020220131135901.522a0ee4RHSA-2022:0544

Frequently Asked Questions

Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.
O3 Security · Impact-Aware SCA

Is GHSA-fp4w-jxhp-m23p in your dependencies?

Find it across RubyGems, including transitive dependencies.

Dependency Confusion in Bundler (High 8.8)