OpenStack Nova Denial of service attack on the compute hostGHSA-ffmh-r67w-m88f
HIGHFix: openstack/nova@0225a61GHSA-ffmh-r67w-m88f is a high-severity (CVSS 7.5) vulnerability in nova. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nova — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nova🐍novaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in OpenStack Nova 15.x through 15.1.0 and 16.x through 16.1.1. By detaching and reattaching an encrypted volume, an attacker may access the underlying raw volume and corrupt the LUKS header, resulting in a denial of service attack on the compute host. (The same code error also results in data loss, but that is not a vulnerability because the user loses their own data.) All Nova setups supporting encrypted volumes are affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | nova | ≥ 15.0.0&&< 15.1.1 | 15.1.1pip install --upgrade 'nova==15.1.1' |
| 🐍PyPI | nova | ≥ 16.0.0&&< 16.1.2 | 16.1.2pip install --upgrade 'nova==16.1.2' |
Affected Products
novaopenstackopenstackredhatResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nova to 15.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-ffmh-r67w-m88f is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 10.0 (Newton) | openstack-nova-1:14.1.0-26.el7ost | RHSA-2018:2714 |
| Red Hat OpenStack Platform 12.0 (Pike) | openstack-nova-1:16.1.4-6.el7ost | RHSA-2018:2332 |
| Red Hat OpenStack Platform 9.0 (Mitaka) | openstack-nova-1:13.1.4-24.el7ost | RHSA-2018:2855 |
Frequently Asked Questions
Is GHSA-ffmh-r67w-m88f in your dependencies?
Find it across PyPI, including transitive dependencies.