NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2019-14433 — nova

MEDIUMFix: openstack/nova@298b337

CVE-2019-14433 is a medium-severity (CVSS 6.5) CWE-209 vulnerability in nova. A fix is available for nova — see the affected versions and patch details below.

OpenStack Nova Server Resource Faults Leak External Exception Details

Also known asGHSA-pg64-r7rr-phv8PYSEC-2019-191
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk+0.04%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.80%1.36%1.92%2.48%1.3%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐍nova🐍nova🐍nova

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in OpenStack Nova before 17.0.12, 18.x before 18.2.2, and 19.x before 19.0.2. If an API request from an authenticated user ends in a fault condition due to an external exception, details of the underlying environment may be leaked in the response, and could include sensitive configuration or other data.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPInovaall versions17.0.12pip install --upgrade 'nova==17.0.12'
🐍PyPInova≥ 18.0.0&&< 18.2.218.2.2pip install --upgrade 'nova==18.2.2'
🐍PyPInova≥ 19.0.0&&< 19.0.219.0.2pip install --upgrade 'nova==19.0.2'

Affected Products

4 products · 10 configurations
OS
ubuntu linuxcanonical
3 versions
16.0418.0419.04
OS
debian linuxdebian
1 version
10.0
Application
novaopenstack
≥ 19.0.0 && < 19.0.2
range
Application
openstackredhat
3 versions
101314

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nova, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nova to 17.0.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2019-14433 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate

Red Hat OpenStack Platform 9 will be retired shortly after the flaw's public date; based on the severity of this vulnerability, it was determined that this fix would not be back ported.

ProductFixed inAdvisory
Red Hat OpenStack Platform 10.0 (Newton)openstack-nova-1:14.1.0-56.el7ostRHSA-2019:2631
Red Hat OpenStack Platform 13.0 (Queens)openstack-nova-1:17.0.10-6.el7ostRHSA-2019:2622
Red Hat OpenStack Platform 14.0 (Rocky)openstack-nova-1:18.2.1-0.20190509150817.8e130e2.el7ostRHSA-2019:2652

Frequently Asked Questions

An issue was discovered in OpenStack Nova before 17.0.12, 18.x before 18.2.2, and 19.x before 19.0.2. If an API request from an authenticated user ends in a fault condition due to an external exception, details of the underlying environment may be leaked in the response, and could include sensitive configuration or other data.
O3 Security · Impact-Aware SCA

Is CVE-2019-14433 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2019-14433: nova — Fixed in 17.0.12