NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

MySQL for Node.js Unsafe OptionsGHSA-f982-mxwc-3mrx

MEDIUMFix: mysqljs/mysql@337e87a

GHSA-f982-mxwc-3mrx is a medium-severity (CVSS 5.5) vulnerability in mysql. A fix is available for mysql — see the affected versions and patch details below.

Also known asCVE-2019-14939
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs31th percentile — riskier than 31% of all scored CVEsHighest risk
0.00%0.29%0.59%0.88%0.1%0.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mysqlnpm
683Kdownloads / week

Description

An issue was discovered in the mysql (aka mysqljs) module 2.17.1 for Node.js. The LOAD DATA LOCAL INFILE option is open by default.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmysql≥ 2.17.1&&< 2.18.02.18.0npm install mysql@2.18.0

Affected Products

1 product · 1 configurations
Application
mysqlmysql_project
1 version
2.17.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mysql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mysql to 2.18.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f982-mxwc-3mrx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An issue was discovered in the mysql (aka mysqljs) module 2.17.1 for Node.js. `The LOAD DATA LOCAL INFILE` option is open by default.
O3 Security · Impact-Aware SCA

Is GHSA-f982-mxwc-3mrx in your dependencies?

Find it across npm, including transitive dependencies.

MySQL for Node.js Unsafe Options (Medium 5.5)