mysql Node.JS Module Vulnerable to Remote Memory ExposureGHSA-5f7m-mmpc-qhh4
Fix: mysqljs/mysql@192fe45GHSA-5f7m-mmpc-qhh4 is a security vulnerability in mysql. A fix is available for mysql — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
mysqlnpmDescription
Versions of mysql before 2.14.0 are vulnerable to remove memory exposure.
Affected versions of mysql package allocate and send an uninitialized memory over the network when a number is provided as a password.
Only mysql running on Node.js versions below 6.0.0 are affected due to a throw added in newer node.js versions.
Proof of Concept:
require('mysql').createConnection({
host: 'localhost',
user: 'user',
password : USERPROVIDEDINPUT, // number
database : 'my_db'
}).connect();
Recommendation
Update to version 2.14.0 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | mysql | ≥ 2.0.0-alpha8&&< 2.14.0 | 2.14.0npm install mysql@2.14.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mysql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mysql to 2.14.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5f7m-mmpc-qhh4 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-5f7m-mmpc-qhh4 in your dependencies?
Find it across npm, including transitive dependencies.