NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2015-9244 — mysql

CRITICAL

CVE-2015-9244 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in mysql. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mysql — see the affected versions and patch details below.

SQL Injection in mysql

Also known asGHSA-fvq6-55gv-jx9f
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.44%1.28%2.11%2.94%0.9%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

8Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mysqlnpm
1.4Mdownloads / week

Description

Versions of mysql prior to 2.0.0-alpha8 are affected by a SQL Injection vulnerability in the mysql.escape() function, which does not properly escape object keys.

Recommendation

Update to version 2.0.0-alpha8 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmysqlall versions2.0.0-alpha8npm install mysql@2.0.0-alpha8

Affected Products

1 product · 7 configurations
Application
mysqlmysqljs
≤ 0.9.6
1 version
2.0.0
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mysql, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mysql to 2.0.0-alpha8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2015-9244 is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

Versions of `mysql` prior to 2.0.0-alpha8 are affected by a SQL Injection vulnerability in the `mysql.escape()` function, which does not properly escape object keys. ## Recommendation Update to version 2.0.0-alpha8 or later.
O3 Security · Impact-Aware SCA

Is CVE-2015-9244 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2015-9244: mysql — Fixed in 2.0.0-alpha8