NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

OpenStack Identity Keystone Privilege Escalation vulnerabilityGHSA-f889-wfwm-6p7m

Fix: openstack/keystone@b17e7be

GHSA-f889-wfwm-6p7m is a CWE-264 vulnerability in keystone. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for keystone — see the affected versions and patch details below.

Also known asCVE-2013-4477PYSEC-2026-831
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 8, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.32%0.63%0.95%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected
🐍keystone

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

The LDAP backend in OpenStack Identity (Keystone) Grizzly and Havana, when removing a role on a tenant for a user who does not have that role, adds the role to the user, which allows local users to gain privileges.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIkeystoneall versions8.0.0a0pip install --upgrade 'keystone==8.0.0a0'

Affected Products

2 products · 2 configurations
Application
grizzlyopenstack
all
Application
havanaopenstack
all
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update keystone to 8.0.0a0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-f889-wfwm-6p7m is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
OpenStack 3 for RHEL 6openstack-keystone-0:2013.1.4-2.el6ostRHSA-2014:0113

Frequently Asked Questions

The LDAP backend in OpenStack Identity (Keystone) Grizzly and Havana, when removing a role on a tenant for a user who does not have that role, adds the role to the user, which allows local users to gain privileges.
O3 Security · Impact-Aware SCA

Is GHSA-f889-wfwm-6p7m in your dependencies?

Find it across PyPI, including transitive dependencies.

OpenStack Identity Keystone Privilege Escalation…