CVE-2025-65073 — keystone
HIGHCVE-2025-65073 is a high-severity (CVSS 7.5) CWE-863 vulnerability in keystone. A fix is available for keystone — see the affected versions and patch details below.
OpenStack Keystone allows /v3/ec2tokens or /v3/s3tokens request with valid AWS Signature to provide Keystone authorization.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-65073.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
keystone🐍keystone🐍keystoneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
OpenStack Keystone before 26.0.1, 27.0.0, and 28.0.0 allows a /v3/ec2tokens or /v3/s3tokens request with a valid AWS Signature to provide Keystone authorization.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | keystone | all versions | 26.0.1pip install --upgrade 'keystone==26.0.1' |
| 🐍PyPI | keystone | ≥ 27.0.0.0rc1&&< 27.0.0 | 27.0.0pip install --upgrade 'keystone==27.0.0' |
| 🐍PyPI | keystone | ≥ 28.0.0.0rc1&&< 28.0.0 | 28.0.0pip install --upgrade 'keystone==28.0.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update keystone to 26.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-65073 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability allows an attacker to obtain a valid OpenStack's Keystone token belonging to a valid user by sending a valid AWS signature to the /v3/ec2tokens or /v3/s3tokens API's endpoints, leading to access to unauthorized resources or privilege escalation within the OpenStack instance. This attack is…
Red Hat has investigated whether a possible mitigation exists for this issue, and has not been able to identify a practical example. Please update the affected package as soon as possible.Source: Red Hat security advisory for CVE-2025-65073 (CC BY 4.0)
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 16.2 | openstack-keystone-1:16.0.3-2.20260616134936.9d699a7.el8ost | RHSA-2026:54757 |
| Red Hat OpenStack Platform 17.1 for RHEL 9 | openstack-swift-0:2.27.1-17.1.20231004180819.el9ost | RHSA-2026:28044 |
| Red Hat OpenStack Services on OpenShift 18.0 | openstack-keystone-1:23.0.3-18.0.20241202141842.9e3dfb4.el9ost | RHSA-2026:1958 |
Frequently Asked Questions
Is CVE-2025-65073 in your dependencies?
Find it across PyPI, including transitive dependencies.