CVE-2026-33551 — keystone
LOWCVE-2026-33551 is a low-severity (CVSS 3.5) CWE-863 vulnerability in keystone. A fix is available for keystone — see the affected versions and patch details below.
OpenStack Keystone: Restricted application credentials can create EC2 credentials
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2026-33551.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
keystoneReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in OpenStack Keystone 14 through 26 before 26.1.1, 27.0.0, 28.0.0, and 29.0.0. Restricted application credentials can create EC2 credentials. By using a restricted application credential to call the EC2 credential creation API, an authenticated user with only a reader role may obtain an EC2/S3 credential that carries the full set of the parent user's S3 permissions, effectively bypassing the role restrictions imposed on the application credential. Only deployments that use restricted application credentials in combination with the EC2/S3 compatibility API (swift3 / s3api) are affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | keystone | ≥ 14.0.0&&< 26.1.1 | 26.1.1pip install --upgrade 'keystone==26.1.1' |
Affected Products
keystoneopenstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for keystone, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update keystone to 26.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-33551 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat OpenStack Platform 13.0 - ELS | openstack-keystone-1:13.0.4-10.el7ost | RHSA-2026:94039 |
| Red Hat OpenStack Platform 16.2 | openstack-keystone-1:16.0.3-2.20260616134936.9d699a7.el8ost | RHSA-2026:54757 |
| Red Hat OpenStack Platform 17.1 for RHEL 9 | openstack-keystone-1:19.0.2-17.1.20260529190847.54dd95d.el9ost | RHSA-2026:28044 |
| Red Hat OpenStack Services on OpenShift 18.0 | openstack-keystone-1:23.0.3-18.0.20260610133808.9e3dfb4.el9ost | RHSA-2026:39808 |
Frequently Asked Questions
Is CVE-2026-33551 in your dependencies?
Find it across PyPI, including transitive dependencies.